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Introduction
This is a guide to the image viewer 
XnView, version 1.9, which you can also 
use for basic image editing, and converting 
images between different image formats. 
It’s free for non-commercial use, and its 
website is at www.xnview.com .

XnView is highly configurable. After you 
have installed the program, it’s 
recommended that you change some of 
the default settings to make some of the 
images and text larger. This is described in 
the Configuration section on page 36.

This guide describes only a small fraction 
of the functionality in XnView. For more 
information, see XnView’s Help.
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Browser and Image View modes

XnView has two main modes: the Browser 
mode, and the Image View mode, and it 
opens in the Browser mode.

The Browser mode is used for looking 
through the contents of folders which 
contain images. Normally these are 
displayed as thumbnails, and there is also 
a Preview pane, which shows a slightly 
larger image of the selected thumbnail. 

In the Image View mode, a single image is 
displayed. You can easily zoom in, pan 
around the image, and switch between the 
images in the same folder. You can also 
rotate, adjust the intensity levels in, resize 
and crop the image, as described in the 
Image Editing section on page 28.
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In addition, there’s a full screen version of 
the Image View mode, which only contains 
an image pane, and makes the maximum 
use of the screen for displaying the picture.

Selecting an image to view

If you want to display an image in the 
Image View mode, then you can either:

• Use the Open dialog from the File 
menu (CTRL + O), which is available in 
both the Browser and the Image View 
modes.

• Use the Tree pane and the Folder 
Contents pane in the Browser mode to 
find the image, and then open it in the 
Image View mode, as described below. 
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Browser Mode

Window Layout

This is similar to Windows Explorer.
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The components of the window are:

• Title bar. The text includes the path of 
the folder selected in the Tree pane.

• Menu bar.

• Tab bar. The first tab is for the 
Browser. The remaining tabs are for the 
images which have been opened, and 
these allow you to quickly move 
between these images. To close a tab, 
choose Close from its shortcut menu 
(CTRL + F4).

• Toolbar.

• Tree pane. This contains a tree view of 
view of all the disks and folders on the 
computer, and this tree has the same 
structure as the Folders tree in 
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Windows Explorer. One folder is always 
selected, and the files contained in this 
folder are shown in the Folder contents 
pane.

• Folder Contents Pane. This displays 
the files which are contained in the 
folder which is selected in the Tree 
pane. More information about this pane 
is given on page 9.

• Preview Pane. This can display a 
larger version of the image selected in 
the Folder Contents pane, together with 
information about the image. More 
information about this pane is given on 
page 10.

• Status bar. When an image is 
selected, the status bar contains 
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various pieces of information about the 
image. If you don’t use it, its display 
can be toggled on and off by choosing 
Status Bar on the View menu.

Moving around the window

You can move around the window using 
the following keystrokes:

• As in any window, to move to the menu 
bar, press ALT, and to leave it press 
ESC.

• Pressing TAB moves you around the 
following components: Tree pane, the 
address edit box on the small toolbar, 
Folder Contents pane, Tree pane etc. 
Note that the address edit box on the 
small toolbar is included in this cycle 
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even if it is not displayed. So to move 
from the Tree pane to the Folder 
contents pane, you have to TAB twice. 
Note that if you move to the Folder 
Contents pane, and initially no image is 
selected, then to select the first image, 
press RIGHT ARROW.

Folder Contents pane

The usual view for the Folder Contents 
pane is thumbnails. However, other views 
are available using the View As sub-menu 
on the View menu.

Navigating through the thumbnails using 
the keyboard:

• RIGHT and LEFT ARROWS for next 
and prior image respectively.
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• HOME and END for first and last image 
respectively.

If any of the images need rotating, see the 
Rotate section on page 28. You can also 
print images, as described on page 22.

Preview pane

If you don’t use the Preview pane and 
want more room for the images in the 
Folder Contents pane, you can toggle the 
display of the Preview pane by choosing 
Show on the Preview pane sub-menu, 
which is on the View menu.

The height of the pane can be easily 
adjusted:

1. Move the cursor to the boundary 
between the Preview pane and the 
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Folder Contents pane, the cursor 
changes to a pair of arrows.

2. Hold down the left mouse button, and 
drag the boundary.

There is an option to have a tabbed pane 
as part or whole of the Preview pane. This 
option can be toggled on and off by 
choosing Use Tabs on the Preview pane 
sub-menu on the View menu. If the option 
is on, then whether the tabbed pane takes 
up none, some or all of the Preview pane 
is controlled by a left and/or right arrow(s) 
which are half-way down the left side of 
the tabbed pane. If you’re going to use the 
tabbed pane, it’s probably best to use the 
whole Preview pane. The tabs then allow 
you to move between the image, and 
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various pages of information about the 
image.

Opening an image in the Image 
View mode

You can open an image in the Image View 
mode by either using the Open dialog on 
the File menu (CTRL + O), or using the 
Tree pane and Folder Contents pane to 
find an image, and then opening it as 
follows:

• Double clicking an image in either the 
Folder Contents pane or the Preview 
pane.

• Selecting an image in the Folder 
Contents pane, and pressing ENTER.
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To return to the Browser from the Image 
View mode, you can:

• Double click anywhere in the image 
pane.

• Press ENTER.

• Click either the Browser button at the 
beginning of the Toolbar, or the 
Browser tab in the Tab bar.

Opening an image in the Full 
Screen Image View mode

You can open an image in the full screen 
version of the Image View mode by either:

• Middle clicking an image in either the 
Folder Contents pane or the Preview 
pane.
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• Selecting an image in the Folder 
Contents pane, and pressing F11.

To return to the Browser:

• Middle click anywhere.

• Press F11 again.
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Image View Mode
The Image View mode is used for 
displaying a single image. There is also a 
Full Screen version of this mode, which 
displays only the image – no menu, 
toolbar, etc. This gives the image the most 
screen space.

In the Image View mode you can:

• Zoom and pan around the image using 
XnView’s built in zoom. You can control 
the zoom and pan using either the 
keyboard or the mouse.

• Switch between images in the same 
folder using either the keyboard or the 
Previous and Next file buttons on the 
Toolbar.

15



• Rotate, adjust the intensity levels in, 
resize, and crop the image – see the 
Image Editing section on page 28.

• Print the image – see the Printing 
section on page 22.

These functions are described in the 
following sections.

Image View Window layout

The components of the window are:

• Title bar. The text includes the name of 
the image.

• Menu bar

• Tab bar. The first tab is for the Browser. 
The remaining tabs are for the images 
which have been opened, and these 

16



allow you to quickly move between 
these images. To close a tab, choose 
Close from its shortcut menu 
(CTRL + F4).

• Toolbar

• Image Pane

• Status bar, which contains various 
pieces of information about the image.

Full Screen Image View Window 
Layout

This is a full screen version of the Image 
View, which consists simply of an image 
pane – there’s no menu, toolbar etc.

The image information at the top left hand 
corner of the screen can be toggled on and 
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off by pressing the key I. If the image 
obscures the information just temporarily 
decrease the magnification. Details of how 
to change the font size of the image 
information are given on page 40.

Image View <> Full Screen Image 
View

You can toggle between the Image View 
and the Full Screen Image View by 
pressing F11, or middle clicking the mouse 
anywhere in the image.

XnView’s Zoom

A computer monitor has about 1M pixels, 
and images from digital cameras have up 
to about 8M pixels. So if an image 
containing a few M pixels is scaled to fit 
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the screen, then not all the detail in the 
image can be shown. There are two 
options for zooming:

• If you use XnView’s built in zoom, then 
it has access to all the data in the 
image, and it can use this to show as 
much detail as possible as you zoom 
in.

• If you use your screen magnifier’s 
zoom, then it can only duplicate the 1M 
pixels which are initially on the screen.

So it’s recommended that if you want to 
zoom in on an image, you temporarily 
disable your screen magnifier, and use 
XnView’s zoom. To disable and enable 
your screen magnifier:
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• For Zoomtext: press ALT + DELETE to 
disable, and ALT + INSERT to enable.

• For Magic: MAGic KEY + DELETE 
toggles the magnification on and off.

Zooming and panning using the 
mouse

You can zoom using the mouse’s scroll 
wheel, and pan by dragging with the right 
mouse button.
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The Numeric Keypad

The numeric keypad can be used for 
zooming, panning and switching between 
images. Num Lock must be off.
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Printing
You can print images in either the Image 
View Mode or Browser Mode. To open the 
Print dialog:

• In the Image View, choose Print from 
the File menu (CTRL + P).

• In the Browser, select one or more 
images, and then choose Print from the 
File menu (CTRL + P).

The Print dialog is a multi-page dialog, 
which also contains a preview pane on the 
right hand side. If you have selected a 
number of images to print, then at the 
bottom of the Preview pane, there are 
forward and back buttons to move through 
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the images. The pages of the dialog are 
described in the following sections.

Printer page

The printer page contains the following 
controls:

• Drop down list box for selecting the 
printer you want to use.

• Configuration button, which opens a 
Print Setup dialog for configuring the 
selected printer. In this dialog you can 
set both the paper size and paper 
orientation (portrait or landscape).

• Copies spinbox, for setting the number 
of copies.
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Layout page

The layout page contains a number of 
sections which are described below. Note 
that throughout the page the units of 
widths, heights, margins etc. are either 
inches or cm, whichever is selected in the 
drop down list box in the units section.

• Page layout. The first control is a drop 
down list box which contains several 
options for the page layout. Below the 
list box are a group of controls which 
depend on which layout has been 
selected. Two of the most useful layout 
options are:

 Single – Best Fit to Page. This gives 
the largest image, whilst maintaining 
the aspect ratio of the image.
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 Single – Custom. This allows you 
set the size of the image using the 
controls below the drop down list 
box.

• Margins. Most printers won’t print right 
up to the edge of the page, so you’ll 
probably want to set the margins to at 
least 1cm.

• Units. The drop down specifies the 
units for the values throughout the 
page, and can be set to either cm or 
inch.

• Position. The drop down list box allows 
the image to be positioned in a variety 
of ways relative to the page, for 
example, Center or Top-Left.
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Caption page

This page contains the following controls:

• Font button, which opens a Font dialog 
which allows you to set the font and 
font size of any caption.

• To the right of the Font button, there’s a 
drop down list box which determines 
whether the caption is above or below 
the image.

• Multi-line edit box, with an Insert button 
immediately below it. If you want no 
caption just delete any contents of the 
edit box. The Insert button opens a 
pop-up menu which has numerous 
options for information about the image 
which you might want to include as part 
of the caption.
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Header/Footer page

This allows you to specify page numbering 
in a header and/or footer. If you don’t want 
any page numbering, just make sure that 
the header and footer check boxes are 
both unchecked.
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Image Editing
The following sections describe how to 
rotate, adjust the intensity levels of, resize 
and crop images.

Rotate

Images can be rotated in any mode. If you 
are in the Browser mode, you need to 
select the image(s) which you want to 
rotate. Then choose one of the options on 
the JPEG Lossless transformations sub-
menu, which is one the Tools menu.

The first time after installing XnView that 
you rotate an image, an information dialog 
opens, warning you that the transformation 
will modify the original file(s). This is 
almost certainly what you want to do, so 
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that you don’t have to rotate the image 
again. So check the “Do not show this 
message again” check box on the dialog, 
and then click OK.

The shortcuts for rotating images left and 
right by 90 degrees are 
CTRL + SHIFT + L, and 
CTRL + SHIFT + R respectively. 
Unfortunately they clash with Zoomtext 
shortcuts, so you must temporarily disable 
Zoomtext to use them (Magicians don’t 
have this problem).

Adjusting intensity levels

Occasionally, images are either too dark or 
too light. XnView allows you to correct for 
this in the Image View mode, either 
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automatically or manually. Try the 
automatic corrections first, and if that 
doesn’t fix it, try the manual correction.

There are two automatic corrections, which 
have similar results:

• Automatic levels. Open the Image 
menu, select the Map sub-menu, and 
choose Automatic levels 
(CTRL + ALT + L).

• Automatic contrast. Open the Image 
menu, select the Map sub-menu, and 
choose Automatic contrast 
(CTRL + ALT + C).

For a manual correction:
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1. Choose Levels from the Adjust sub-
menu on the Image menu. The Adjust 
dialog opens.

2. The Adjust dialog contains:

 Before and After image panes.

 A histogram pane, which shows the 
distribution of the intensity levels in 
the image.

 Black and White point spin boxes. 
These can be adjusted either by 
clicking on the up and down arrows, 
or by selecting one and using the 
UP and DOWN ARROW keys.

3. If the image is too dark, then reduce the 
White point spin box so that the right 
hand arrow at the bottom of the 
histogram pane is underneath the right 
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hand end of the histogram, or the 
image in the After pane looks OK.

4. If the image is too light, then increase 
the Black point spin box so that the left 
hand arrow at the bottom of the 
histogram pane is underneath the left 
hand end of the histogram, or the 
image in the After pane looks OK.

5. Click OK.

After you have made the changes, choose 
either Save or Save As from the File 
menu, depending on whether you want to 
overwrite or preserve the original image.

Resize

A common reason for wanting to resize an 
image is to send a smaller version of an 
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image via email, so that the image is 
quicker to send. If you reduce the 
dimensions to about 1024 or less, then the 
file size will probably be small enough.

1. Display the image you want to resize in 
the Image View window.

2. Choose Resize from the Image menu.

3. The Resize dialog opens. In the Screen 
Size section, the width and height of 
the image are given in pixels. If you 
type in a new width or height, the other 
value will automatically updated, as 
long as the “keep ratio” check box, near 
the bottom of the window, is still 
checked. After you have made the 
changes, click OK or press ENTER.
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4. Choose either Save or Save As from 
the File menu, depending on whether 
you want to overwrite or preserve the 
original image.

Crop

1. Display the image you want to crop in 
the Image View window.

2. You first have to draw a rectangle on 
the image, which is the area you want 
to keep. To do this:

A. Move the cursor to the top right 
hand of the area.

B. Start holding down the left hand 
mouse button.

C. Drag the cursor to the bottom right 
hand corner of the area.
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D. Let go of the mouse button

Once you have drawn the rectangle, 
you can adjust it using the handles at 
the corners, and at the midpoints of the 
sides. If you want to cancel the 
rectangle, just click anywhere outside 
the rectangle.

3. Choose Crop from the Edit menu.

4. Choose either Save or Save As from 
the File menu, depending on whether 
you want to overwrite or preserve the 
original image.
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Configuration
This section describes some 
recommended changes to XnView’s 
default settings.

Tree pane tabs

In the Browser mode, by default there are 
a set of tabs at the top of the Tree pane. 
These aren’t very useful, and clutter up the 
window, so to remove them:

1. On the View menu, there’s a Tree pane 
sub-menu which contains the item Use 
tabs.

2. If there’s a tick in front of Use tabs, then 
this indicates that a set of tabs are 
shown at the top of the Tree pane. If 
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this is the case, click Use tabs, and this 
will turn off the tabs.

Small toolbar

In the Browser mode, by default there’s a 
small toolbar at the top of the Folder 
Contents pane. This isn’t particularly 
useful, so you may want to remove it. The 
View menu contains the item “Small 
toolbar”, and a tick in front of this item 
indicates that the Small toolbar is 
displayed. If this is the case, then click this 
item, and the Small toolbar will not be 
displayed.

Thumbnail size

To make the thumbnails in the Browser 
mode bigger: on the View menu, select the 
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Thumbnails Size sub-menu, and choose 
192 x 144.

Options dialog

The remaining configuration settings in the 
sections below are set using the Options 
dialog, which is on the Tools menu.

On the left hand side of the dialog, there’s 
a pane which contains a list of categories. 
If you select one of the categories in this 
pane, you can then set the options for this 
category in the right hand pane. The 
controls in the right hand pane are 
grouped into pages, like in a multi-page 
dialog, and so at the top of this pane, there 
are one or more tabs which allow you to 
choose the page.
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Thumbnail quality

In the Options dialog:

1. Select the thumbnails category.

2. On the right hand pane, make sure 
you’re on the Appearance page.

3. Near the top of the page, set the “Use 
high quality” check box to checked, and 
the “Use Embedded thumbnail” check 
box to unchecked.

Auto Image size

In the Options dialog:

1. Select the View category.

2. One the right hand pane, make sure 
you’re on the View page.
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3. The “Auto Image Size” combo box is 
near the top of the page. Set this to “Fit 
image to window, all”.

Image Information in the Full 
Screen Image View

In the Options dialog:

1. Select the Fullscreen category.

2. One the right hand pane, there’s a 
large text box in the lower half of the 
pane. Just above this text box, make 
sure that the “Show information” check 
box is checked.

3. By default, the information shown in the 
fullscreen mode is the directory and the 
filename. However, with a large font 
size, the text string becomes too long. 
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So in the text box, delete the text 
<Directory>, leaving only the text 
<Filename>.

4. Just below the text box, press the Text 
settings button.

5. A Text settings dialog opens. Click the 
Choose button, at the top right hand 
corner.

6. A Font dialog box opens. Set the font to 
Verdana, and try a font size of 48, for 
starters. Click the OK button, at the top 
right hand corner.

7. In the Text settings dialog, click the OK 
button at the bottom left hand corner.
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