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Introduction
This is a guide to the image viewer 
XnView, version 1.8, which you can also 
use for basic image editing, and converting 
images between different image formats. 
It’s free for non-commercial use, and its 
website is at www.xnview.com  .

XnView is highly configurable. After you 
have installed the program, you should 
change some of the settings to make some 
of the images and text larger. This is 
described in the Configuration section on 
page 34.

This guide describes only a small fraction 
of the functionality in XnView. If you want 
to know more, you could start by reading 
XnView’s Help.

2



Image View and Browser modes

XnView has two modes: the Image View 
mode, and the Browser mode, and it 
opens in the Browser mode. Each mode 
has a different window layout.

In the Image View mode, a single image is 
displayed. You can easily zoom in, pan 
around the image, and switch between the 
images in the same folder. You can also 
rotate, adjust the intensity levels in, resize 
and crop the image, as described in the 
Image Editing section on page 26.

The Browser mode is used for looking 
through the contents of folders which 
contain images. Normally these are 
displayed as thumbnails, and there is also 
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a Preview pane, which shows a larger 
image of the selected thumbnail. 

Selecting an image to view

If you want to display an image in the 
Image View mode, then you can either:

• Use the Open dialog from the File 
menu, which is available in both the 
Image View and the Browser mode.

• Use the Folder tree and the Folder 
Contents pane in the Browser mode to 
select the image, and then switch to the 
Image View mode. Since the images in 
this mode are a lot smaller than in the 
Image View mode, some may prefer 
just to use the Open dialog.

4



Browser Mode

Window Layout

This is similar to Windows Explorer.

Title bar
Menu bar
Tab bar
Main Toolbar

Folder
Tree

Toolbar Address bar

Folder Contents Pane

Preview Pane

Status bar
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The components of the window are:

• Title bar. The text includes the path of 
the folder selected in the Folder tree.

• Menu bar.

• Tab bar. The tabs are labelled with the 
filenames of images you have opened, 
and allow you to quickly move between 
images. There’s also a tab for the 
Browser. If you don’t use this bar, you 
can switch it on and off by choosing 
Tabs on the View menu.

• Main toolbar.

• Folder tree. This is a view of all the 
disks and folders on the computer, and 
has the same structure as the Folders 
tree in Windows Explorer. One folder is 
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always selected, and the files contained 
in this folder are shown in the Folder 
contents pane.

• Toolbar for the Folder Contents pane.

• Address bar. This contains the path of 
the folder selected in the Folder tree.

• Folder Contents Pane. This displays 
the files which are contained in the 
folder which is selected in the Folder 
tree. This is described in more detail on 
page 10.

• Preview Pane. This displays an image 
of the file which is selected in the 
Folder Contents pane. The height of 
the pane can be easily adjusted:
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A. Move the cursor to the boundary 
between the Preview pane and the 
Folder Contents pane, the cursor 
changes to a pair of arrows.

B. Hold down the left mouse button, 
and drag the boundary.

• Status bar. The cells in the status bar 
contain the following information when 
an image is selected:

A. The number of files in the folder, 
and other info.

B. The name of the file

C. The width and height in pixels, and 
the number of bits to store each 
pixel, eg 1024 x 768 x 24.

D. Colour information.

E. The size of the file, in KB.
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F. The magnification of the image in 
the Preview pane.

Moving around the window

You can move around the window using 
the following keystrokes:

• As in any window, to move to the menu 
bar, press ALT, and to leave it press 
ESC.

• Pressing TAB moves you around the 
following components: Folders tree, 
Address bar, Folder Contents pane, 
Folder Tree etc. Pressing SHIFT + TAB 
moves in the opposite direction. Note 
that if you move to the Folder Contents 
pane, initially no image is selected — to 
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select the first image, press RIGHT 
ARROW.

Folder Contents pane

The usual view for the Folder Contents 
pane is thumbnails. However, other views 
are available using the View As sub-menu 
on the View menu.

Navigating through the thumbnails using 
the keyboard:

• RIGHT and LEFT ARROWS for next 
and prior image respectively

• HOME and END for first and last image 
respectively.
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If any of the images need rotating, see the 
Rotate section on page 26. You can also 
print an image, as described on page 22.

Browser <> Image View

You can move from the Browser to the 
Image View by either:

• Double clicking either a thumbnail or 
the preview pane.

• Selecting an image in the Folder 
Contents pane, and pressing ENTER.

To return to the Browser, you can:

• Double click anywhere in the image 
pane

• Press ENTER.
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Browser <> Full Screen Image 
View

You can move from the Browser to the Full 
Screen Image View by either:

• Middle click either a thumbnail or the 
preview pane.

• Select an image in the Folder Contents 
pane, and press F11.

To return to the Browser:

• Middle click anywhere.

• Press F11 again.

Switching to the Browser mode

In addition to the methods of switching 
between modes given above, you can 
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always return to the browser by pressing 
CTRL + B. Also, if you’re in the Image 
View mode, then you can click the browser 
button, which is on the far left of the 
toolbar.

Opening an image

Instead of using the Folder tree and the 
Folder Contents pane to select an image 
to view in the Image View mode, you can 
use the Open dialog which is on the File 
menu ( or CTRL + O ).

After you have selected the image you 
want to open, click Open or press ENTER, 
and the image will be displayed in Image 
View mode.
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Image View Mode
The Image View mode is used for 
displaying a single image. There is also a 
Full Screen version of this mode, which 
displays only the image — no menu, 
toolbar, etc. This gives the image the most 
screen space.

In the Image View mode you can:

• Zoom and pan around the image using 
XnView’s built in Zoom. You can control 
the zoom and pan using either the 
numeric keypad or the mouse.

• Switch between images in the same 
folder using the numeric keypad.
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• Rotate, adjust the intensity levels in, 
resize, and crop the image — see the 
Image Editing section on page 26.

• Print the image — see the Printing 
section on page 22.

These functions are described in the 
following sections.

Image View Window layout

The components of the window are:

• Title bar. The text includes the name of 
the image.

• Menu bar

• Tab bar. The tabs are labelled with the 
filenames of images you have opened, 
and allow you to quickly move between 
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images. There’s also a tab for the 
Browser. If you don’t use this bar, you 
can switch it on and off by choosing 
Tabs on the View menu.

• Toolbar

• Image Pane

• Status bar. Contains the following 
information for the image displayed:

A. Current image number/N, where N 
is the number of files in the folder

B. Filename

C. The width and height in pixels, and 
the number of bits to store each 
pixel, eg 1024 x 768 x 24.

D. Colour information.

E. Size of the file in KB.
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F. Magnification of the image.

Full Screen Image View Window 
Layout

This is a full screen version of the Image 
View, which consists simply of an image 
pane — there’s no menu, toolbar etc.

The image information at the top left hand 
corner of the screen can be toggled on and 
off by pressing the key I. If the image 
obscures the information just temporarily 
decrease the magnification. Details of how 
to change the font size of the image 
information are given on page 36.
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Image View <> Full Screen Image 
View

You can toggle between the Image View 
and the Full Screen Image View by 
pressing F11, or middle clicking the 
mouse.

XnView’s Zoom

A computer monitor has about 1M pixels, 
and images from digital cameras have up 
to about 8M pixels. So if an image 
containing a few M pixels is scaled to fit 
the screen, then not all the detail in the 
image can be shown. There are two 
options for zooming:

• If you use XnView’s built in zoom, then 
it has access to all the data in the 
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image, and it can use this to show as 
much detail as possible as you zoom 
in.

• If you use your screen readers zoom, 
then it can only duplicate the 1M pixels 
which are initially on the screen.

So it’s recommended that if you want to 
zoom in on an image, you temporarily 
disable your screen magnifier, and use 
XnView’s zoom. To disable and enable 
your screen magnifier:

• For Zoomtext: press ALT + DELETE to 
disable, and ALT + INSERT to enable.

• For Magic: MAGic KEY + DELETE 
toggles the magnification on and off.
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The Numeric Keypad

The numeric keypad can be used for 
zooming, panning and switching between 
images. Num Lock must be off.

Reset
Zoom

Zoom
Out

First
Image

Pan
Up

Prior
Image

Pan
Left 5 Pan

Right

Zoom
In

Last
Image

Pan
Down

Next
Image
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Zooming and panning using the 
mouse

You can zoom using the mouse’s scroll 
wheel, and pan by dragging with the right 
mouse button.

Opening an image

To open an image, choose Open from the 
File menu ( or CTRL + O ). Note that the 
shortcut also works in the Full Screen 
version, even though no menu is visible.
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Printing
You can print an image in either the Image 
View Mode, or Browser mode. To print, 
select Print from the File menu, or press 
CTRL + P.

Each time you run XnView, the first time 
you print an image you have to go through 
two print dialogs, but for subsequent prints, 
only the second one.

First print dialog

This is a multi-page dialog. It opens on the 
general page, which allows you to select a 
printer, if you have more than one. The 
names of the other pages depend on your 
printer, and allow you to set options such 
as the print quality.
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After you have made any changes, click 
the print button at the bottom of the dialog, 
or press ENTER. The second Print dialog 
opens.

Second print dialog

This allows you to set a number of options 
for printing, and is divided into the 
following sections:

• Size. There’s a combo box with a 
number of options, which include:

 Best Fit to Page. This gives the 
largest image, whilst maintaining the 
aspect ratio of the image.

 Custom. You can specify the width 
and height of the image in inches or 
cm. There’s also a check box to 
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select whether you want to maintain 
the aspect ratio of the image.

• Orientation. A set of two radio buttons: 
Portrait and Landscape.

• Unlabelled section. This includes a 
“Center on Page” check box. If this is 
unchecked, the image moves to the top 
left hand corner.

• Show info. The text box shows the 
information that is printed above the 
image. If you don’t want any text, just 
select all the text, and delete it. You 
can use the Insert button below the text 
box to add extra fields.

• Preview. This shows the size and 
position of the printed image relative to 
the paper.
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After you have set the desired options, 
click Print at the bottom left hand corner, or 
press ENTER.
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Image Editing

Rotate

Images can be rotated in any mode. If you 
are in the Browser mode, you need to 
select the image(s) which you want to 
rotate. Then choose one of the options on 
the JPEG Lossless transformations sub-
menu, which is one the Tools menu.

The first time after installing XnView that 
you rotate an image, an information dialog 
opens, warning you that the transformation 
will modify the original file(s). This is 
almost certainly what you want to do, so 
that you don’t have to rotate the image 
again. So check the “Do not show this 
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message again” check box on the dialog, 
and then click OK.

The shortcuts for rotating images left and 
right by 90 degrees are 
CTRL + SHIFT + L, and 
CTRL + SHIFT + R respectively. 
Unfortunately they clash with Zoomtext 
shortcuts, so you must temporarily disable 
Zoomtext to use them ( Magicians don’t 
have this problem ).

Adjusting intensity levels

Occasionally, images are either too dark or 
too light. XnView allows you to correct for 
this in the Image View mode, either 
automatically or manually. Try the 
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automatic correction first, and if that 
doesn’t fix it, try the manual correction.

There are two automatic corrections, which 
have similar results:

• Automatic levels: either press 
CTRL + ALT + L, or choose Automatic 
levels from the drop-down menu of the 
Adjust button on the toolbar.

• Automatic contrast: either press 
CTRL + ALT + C, or choose Automatic 
contrast from the drop-down menu of 
the Adjust button on the toolbar.

For a manual correction:

1. Choose Levels from the Adjust sub-
menu on the Image menu. The Adjust 
dialog opens.
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2. The Adjust dialog contains:

 Before and After image panes.

 A histogram pane, which shows the 
distribution of the intensity levels in 
the image.

 Black and White point spin boxes. 
These can be adjusted either by 
clicking on the up and down arrows, 
or by selecting one and using the 
UP and DOWN ARROWS.

3. If the image is too dark, then reduce the 
White point spin box so that the right 
hand arrow at the bottom of the 
histogram pane is underneath the right 
hand end of the histogram, or the 
image in the After pane looks ok.
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4. If the image is too light, then increase 
the Black point spin box so that the left 
hand arrow at the bottom of the 
histogram pane is underneath the left 
hand end of the histogram, or the 
image in the After pane looks ok.

5. Click OK.

After you have made the changes, choose 
either Save or Save As from the File 
menu, depending on whether you want to 
overwrite or preserve the original image.

Resize

A common reason for wanting to resize an 
image, is to send a smaller version of an 
image via email, so that the image is 
quicker to send. If you reduce the 
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dimensions to about 1024 or less, then the 
file size will probably be small enough.

1. Display the image you want to resize in 
the Image View window.

2. Choose Resize from the Image menu.

3. The Resize dialog opens. In the Screen 
Size section, the width and height of 
the image are given in pixels. If you 
type in a new width or height, the other 
value will automatically updated, as 
long as the “keep ratio” check box, near 
the bottom of the window, is still 
checked. After you have made the 
changes, click OK or press ENTER.

4. Choose either Save or Save As from 
the File menu, depending on whether 
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you want to overwrite or preserve the 
original image.

Crop

1. Display the image you want to crop in 
the Image View window.

2. You first have to draw a rectangle on 
the image, which is the area you want 
to keep. To do this:

A. Move the cursor to the top right 
hand of the area.

B. Start holding down the left hand 
mouse button.

C. Drag the cursor to the bottom right 
hand corner of the area.

D. Let go of the mouse button
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Once you have drawn the rectangle, 
you can adjust it using the handles at 
the corners, and at the midpoints of the 
sides. If you want to cancel the 
rectangle, just click anywhere outside 
the rectangle.

3. Choose Crop from the Edit menu.

4. Choose either Save or Save As from 
the File menu, depending on whether 
you want to overwrite or preserve the 
original image.
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Configuration

Thumbnail size

On the View menu, select the Thumbnails 
Size sub-menu, and choose 192 x 144.

Options dialog

The remaining configuration settings in the 
sections below are set using the Options 
dialog, which is on the Tools menu.

On the left of the dialog, there’s a Category 
Pane. If you select one of the categories in 
this pane, you can then set the options for 
this category in the right hand pane.
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Thumbnail quality

In the Options dialog:

1. Select the Browser: thumbnail category

2. “Use high quality” check box — set to 
checked.

3. “Use Embedded thumbnail” — set to 
unchecked.

Auto Image size

In the Options dialog:

1. Select the View category

2. The “Auto Image Size” combo box is 
near the top of the View section. Set 
this to “Fit image to window, all”.
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Image Information in the Full 
Screen Image View

In the Options dialog:

1. Select the View: Fullscreen category

2. Just above the large text box, make 
sure that the “Show information” check 
box is checked.

3. By default, the information shown is the 
directory and the filename. However, 
with a large font size, the text string 
becomes too long. So in the text box 
below, delete the text <Directory>, 
leaving only the text <Filename>.

4. Just below the text box, press the Text 
settings button.
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5. A Text settings dialog opens. Click the 
Choose button, at the top right hand 
corner.

6. A Font dialog box opens. Set the font to 
Verdana, and try a font size of 48, for 
starters. Click the OK button, at the top 
right hand corner.

7. In the Text settings dialog, click the OK 
button at the bottom left hand corner.
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